Facing an issue where Flex Modules are not getting recognised by QTP?

21 10 2009

This is a regression bug in the automation swcs for sdk 3.4 where in flex modules loaded using module loader are not being recognised by the Automation framework and in turn are not getting recorded in the QTP script.In case this issue is blocking your work Adobe has fixed it and uploaded the corresponding automation swcs containing that fix. Go to http://bugs.adobe.com/jira/browse/FLEXENT-1088 .Please note these AT swcs are compatible with the sdk 3.4.1 which came along with the beta 2 Flash Builder  .

Advertisements

Actions

Information

7 responses

21 10 2009
Facing an issue where Flex Modules are not getting recognised by QTP? | Adobe Tutorials

[…] In case this issue is blocking your work Adobe has fixed it and uploaded the corresponding automation swcs containing that fix. Go to http://bugs Originally posted here: Facing an issue where Flex Modules are not getting recognised by QTP? […]

21 01 2010
Deepak

Hi ,

I am testing the flex application at

http://examples.adobe.com/flex2/inproduct/lcds/flexstore/flexstore.html

and my environment is QTP 10 and flex and air add-in –Adobe Flex 4 Plugin for HP QuickTest Pro.

I am able to record the flex object without any issue.

But the issue is object property is not displayed for the added flex objects in object repository.

any idea on where iam missing ?

Thanks,
-Deepak

21 01 2010
svakil

Hi
I think what your trying to say is that you are not getting code hinting for the objects present in the object repository ? This is a known issue with QTP 10 and we will be fixing it .For the time being there is a workaround which i have mentioned in my blog entry https://shanazvakil.wordpress.com/2009/09/25/code-hinting-for-flex-operations-not-appearing-in-qtp-10/ Let me know if this helps.

1 10 2010
Shashank

Hi Deepak,

i’ve installed QTP 10 and then i have installed flex 4 add in. and when i’m trying to record the flexstore application it records something with co-ordinates on micromediaflash player activex. It is not able to recognize the flex object.

could you please help me?

Thanks
-Shashank

7 05 2010
khalid

Hi,

I am tryin to automate flex application.after compiling with the libraries qtp does recognise the first page that gets displayed but after navigating ot other pages qtp recognises all the objects on it as winobjects.Am i missing anything.

i am using sdk version 3.2 libraries

7 05 2010
svakil

Hi
Do you have any custom components present on the other pages ? As the uatomation framework requires the user to write custom delegates for custom cmponents used and qtp does not recognise it by itself so maybe the external container is a custom component?

1 10 2010
Shashank

Hi,
i’ve installed QTP 10 and then i have installed flex 4 add in. and when i’m trying to record the flexstore application it records something with co-ordinates on micromediaflash player activex. It is not able to recognize the flex object.

could you please help me?

-Shashank

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s




%d bloggers like this: